Herelink video works or not at random with EKEN H9R

Hi Everyone!

We have built for our company 4 identical drones for special spraying tasks, all using Herelink. Everything works like a charm, except for the Herelink (latest firmware, QGC, Arducopter 4.0.7). Here are the issues:

  1. 2 units out of 4 can not see some of the wifi networks we can use with the other 2 units. We tried with 5ghz, 2.4, all the possible settings, but still half of the units can not see around half of the wifi networks we tried. It is not a huge issue since it can work, but it is a bit frustrating that on the field we can not use hotspots for loading the map. Is there any solution for this? I read all the topics I could find, but nothing.

  2. Video stream. We use an EKEN H9R which is on the compatible camera list with a quality 1m long micro to micro hdmi cable. The problem is that sometimes we have video ont the herleink, sometimes we dont. It is totally random, there is not pattern at all. We tried powering the camera before, after and during powering the Herelink, we tried multiple different hdmi cables, updating the air unit, everything. Sometimes we have image right away, than its gone mid flight. Sometimes we can only see the waiting for video text, and than a few minutes later we suddenly have image. Basically I could list all the possible versions of having and not having video, like I said, it is totally random. It does not matter if we are inside, outside, mid flight, before flight, after flight. Sometimes it works, sometimes not. No pattern at all. Thats the case with all 4 drones we have. What could this be? How we can make sure to have reliable video?

Thanks, any help is appriciated.

Also, whenever we change battery, the onboard voltage and other telemetry items stop sending the real time data, and they are frozen to the last number it showed right before disconnecting the old battery. If we restart the Herleink transmitter, than its okay again, but only until the first drone on/off.
It seems rather strange, we have been playing with this for weeks no, we did hundreds of test in the workshop and we can not get the same result 3 times in a row. Right now if it works after turning everything on, than it wont work after the first simulated battery swap. Or if it is working 2 times, than it wont work on the 3rd. Or if it works indeed, than we dont have telemetry data. Unfortunatelly right now It not usable, since we really need the telemetry and the video.

Plug a chip into the camera and start recording from the ground. Plug in the hdmi cable after starting the recording. Check if the camera has 15, 30 etc… auto shut off. Fix the camera cable and, if any, the converter, the plug-ins, vwe sockets, with a plastic screw.

I’ve had these problems. These problems have not occurred for a long time:

Sounds like you probably have some settings misconfigured.
If you look at the documentation manual and you will see that the Herelinks are 5gHz Wifi only.

This generally means you have some issues with your antenna placement or interference from other systems on the aircraft.

Have you configured and become familiar with the units before installing them on the aircraft?

hi Craig!

No, we did not misconfigured, this is like the 50th Herleink we used, I know Herelinks are 5gHz, I know the documentation by the letter. And all the 4 units were configured the same. Also some of our partners are having similar issues with the Wifi on new Herelink units, so it is definitelly not a configuration error.

About the interference, also, no. We checked in an EMC laboratory, everything is fine.

And yes, we configured everythig according to the documentation, we have plenty of experience with Herleink. The only variable that is new compared to the other 50 drones we have built, is the EKEN H9R camera, and that these 4 Herlelink units are brand new, compared to the older fimrware versions we use on other drones.

Altough we have some progress: whenever we use the EKEN with no SD card, and give an 8 second delay to the camera power, it works. If we put an SD card in and power the camera together with the drone wit a BEC, it works totally randomly. Strange.

re wifi, change the zone to FCC/EU and then back again, and then try

re your camera, when the sd card is in, can you confirm the output resolution? Gopro for example modify the output resolution if recording at the same time.

Hi Michael,

first of all, Im a huge fan, all this you created is amazing, thanks!

About the wifi, we tried what you wrote, not working for us. The newer Herelinks we bought in the last couple of month, can only see wifi networks randomly. We tried basically all the wifi settings possible, and can not get the hang of it. Also, any other wifi capable device (smartphone, notebook, tablet, gopro) works on the same 5ghz wifi networks that the Herelink can not see. As a weird addition, we have two wifi in our office, both are seen by the Herelink, but only one can be used to download the updates when turned on the first time. On the other, it always has an error somewhere between 15-50%.

About the video. First of all we dont need recording, we just need the camera for FPV. We choosed the EKEN since it can be turned on by suppying power, and it was on the list, so it is a very conviniant solution for us. Theoretically we just have to plug the main battery, and the video should work. But it only works like 30% of the time, totally randomly.
The output resolution is 1080p 30fps, but we tried all other possible settings, none works stable.
on the weekend we had some other strange events, so to sum up here are the few certainties we could found, with latest everything.

  • EKEN H9R without SD card with 8 sec delay (Air Unit is ready, 2 led light is on) works. But after the first battery change, the telemetry on the QGC freezes and we get no real time battery or Lidar readings, but if we connect to Mission Planner via the Herelink wifi hotspot, we get live readings while the video is most of the time gone. But this bulletpoint altough is quite sure, also has exceptions, when somethnig other happens.
  • Using the EKEN (all 4 units we have right now, powered from the drone the same way we would do) with any other HDMI device like a projector, half a dozen of LCD monitors, is working like a charm.
  • Using laptops instead of a camera, we get video on the Herelink, but only after 60-70sec, while the screen on herelink blinks black for multiple times like when the laptop’s video card is changing output mode.

We are open to any solution, since we have spent like 20 hours trying to understand and solve this issue, and it seems to us that the weak point is the Herelink, since any part of the config works alone, except when the Herleink is in the picture. Right now we are working measuring if the EKEN has a reliable 5V and GND on the hdmi out, and if we add a stable power could maybe help.
UPDATE: the stable 5V does not help, unfortunatelly.

thanks!

hi Everyone,

just a short update: we tried everything and the bottom line is this: all the parts including the video system (camera, power source, hdmi cable, power cable for camera) is working perfectly alone, or in another sytem, but when we use the Herelink, the stream is totally unreliable and the issue is so random it makes no sense.
If anyone out there is open help, we are willing to pay for the services since we spent 40 hours trying to solve it, but since we can and will not mess with the Herelink, and we checked all other components 100%, we are out of options.

Thanks!

I have exactly the same issue with the camera (Sony a7RM4a), and also tried a different camera and a raspberry pi (with different cables). All the same issue. I’m running the latest firmware on both the air unit and ground unit. Sometimes it works, usually it doesn’t.

Original post: Herelink video livestream problems

Hi Everyone!

A quick update, we still have these issues and there is no more options we can try (check previous posts), and since there is no traditional tech support (which we totally understand), we would be happy to donate to the developers, to solve these issues we are experiencing, since right now all the advantages of this system is useless wothout these basic functions below:

  1. video stream unreliable and totally random if it works or not, but mostly not
  2. telemetry freezes every time after changing battery
  3. Herleink is not seeing half the 5ghz wifi networks, which is quite bad in the field

Thanks!

Hi there,
I have two new herelink systems (updated to latest versions) now and I am also experiencing the same problems when connecting any camera to the Herelink HDMI. 50% it works, 50% it definitely does not, even causing my action cameras to freeze sometimes (Eken, Thieye, other Asus hdmi device too). Regardless which cable I use, which power source is herelink on, when do i connect or turn the camera on. Last Year these cameras were just working fine, I suspect only firmware was upgraded on the newer air units, maybe if I could try downgrading the firmware?

Hi everyone!

We have experienced similar issues like @Károly_Bence_Ludvigh. Is there any solution to this? It is very uncomfortable to restart QGC on herelink controller every time, when our telemetry isnt working properly after battery change, or the camera didnt start.

Can you help us? @CraigElder @Michael_Oborne

please provide a bugreport from the air unit, without depowering it, and after the issue has occured

NOTE from the AIR unit, not the GCS unit

This “generate a bug report” article shows only how to pull the report from the Herelink remote as I understand.

How do I generate the report on the Air unit?

connect usb to the air unit,
and
adb bugreport

Thanks, it worked. Here is the file.
bugreport-N2G47J-2022-06-27-09-12-34.zip (1.2 MB)

Hi Everyone!

We also got the bug reports as per Michael asked.
We have two versions, this one is when the video simply not works from the beginning:
bugreport-N2G47J-2022-06-28-13-03-37.zip (1.1 MB)
And this second one is when for some reason the video is fine after turning the system on, but than it just freezes:
bugreport-N2G47J-2022-06-28-13-19-57.zip (997.9 KB)

hope it helps, and thanks a lot! If there is anything we can help with, we woul be happy to!