Gone to the site downloaded the “Google GPS Driver” then proceeded to download “Flasher_win” and open the file so that I can make a shortcut to my desktop. I then connect the lipo battery to the “Air Unit” and plug in the ubs cable to computer. It dings and says there is a error with something on the ‘Air Unit’ then ding seconds later saying its ready so I click the “Flasher_win” icon and it gives me a warning and I run it anyways and it pops up for literally a few seconds saying looking for device and connects to something because it shows a quick glimpse of some files running but immediately disappears, Then nothing…

I even tried extracting the files of “Flasher_win” and doing the steps all over.

Could anyone please explain in detail what you did from the point of downloading the “Flasher_win” & “Google GPS Driver” to get it to follow thru with the update, I’m not the best with technical terms so breaking it down as best as possible really helps
Please & Thank You🙂!

Idk if these pictures help but this is what pops up when I go into device manager idk what to do with this information…

I assume this is typo of Google USB driver.

Can you execute the flasher_win.exe from console, and capture the error message?

Yes I didn’t mean to type “GPS Driver” above⬆️
I instead meant “Google USB driver”
This black box is what pops up for only a very brief 1 sec when trying to flash the air unit before it crashes quickly…

I’ve also included 2 videos below of exactly everything I’m doing step by step, so please let me know what I’m doing wrong or anything else I need to be trying


Might be related to Google driver not being correctly installed.

You may try this:

I uploaded 2 videos showing me downloading the “Google USB driver” can’t be that has to be something else…?

Cannot see that you installed the driver in your videos. You just downloaded it. Maybe I overlooked it. However, still think you need to install the driver….

My apologies I thought when you download the “Google usb driver” it’s actually automatically installing at the same time time?
I do extract the file once it’s been downloaded is this the same as installing it? If not how do you install it after downloading?
If it’s complicated to explain can you provide a reference of a YouTube video that’s similar to the process…?

Nothing automatically install itself after downloading…otherwise that’s a huge security threat.

You can have a look at this. There are some pictures so you can follow with


I dropped this air unit off to a computer expert because I was having difficulties in getting the firmware update going & he explained that he downloaded the “Google USB Driver” on my laptop & performed the necessary firmware update to the Herelink Air unit. I was unable to bind the remote with the air unit upon receiving the u it back so my only assumption is that maybe the forward update wasn’t performed properly. When I hook up my the Herelink air unit & I try to personally flash the firmware this is what pops up!
Is this what is suppose to pop up even if it’s been flashed once already? Is their some place I can look at to verify if it’s updated properly?

No. This error message should show up if the update was successful.
It tells you that the USB driver is still not working.
Try to completely remove the old driver and install the Google USB driver again.
Or, try to update on another computer, which is probably the easiest way.

Did you mean to say that this message should not show up if it was updated correctly?


@King_Lovin Did you get this resolved? Looks like I have the same issue. Tried everything, and no dice!

I did get it fixed… what you have to do is change the driver out on your computer

Okay cool! Can you provide me with instructions how you changed the driver. Thanks!

At this point I’m tired of trying stuff, and would like to follow your method.

Tbh I paid a computer tech $200 to come fix it. I knew what needed to be done I just didnt know how to do it because my computer was giving me a hard time…

You need to be able to go to your start menu & look up or look for “Device manager” which will look similar to this…

Once you connect Herelink this is what happens
Depending on which computer you have certain things may be listed with diff names because I had 1 computer that showed “Universal USB Device” & another computer I tried this process on would pop up “Portable Devices”

From their you click on the appropriate name that is being used for your HERELINK & you right click on the folder & click on properties

From their you’ll look for update driver and click on it

This is where I would get stuck at everytime because once you click on “Update Driver” you’ll then see an option where it ask you
“Do you want to search for update automatically” or another option
“Do you want to manually update the driver”
“Manual update” is the one you want to click on.
The issue is that my computer would always say
“Cannot update, driver already updated to newest version”
You have to be able to disable and override security permissions on your computer to be able to install the driver which even then I couldn’t do…
This is as far as I can help you my friend unfortunately I had to pay a computer tech $200 to install the driver of my choice
If you look around for someone in your area who is familiar with computers they will more then likely do it for $35-40 dollars for you I only paid $200 because I didn’t wanna wait 2-3 days I needed mine done the same day

1 Like

Thank you very much sir! I have tried this, but your advice to get someone to look into manually override it sounds like the best option. I will post my findings. That’s again friend.

Last minute advise… I called 10 different computer places and described to them my issue, the ones that I just kept it very simple and sweat explaining that I just needed a driver downloaded and installed they only wanted $30-45 dollars
The computer techs that I went into more technical details with explaining it was for a drone & that these exact steps needed to be taken so that I could update my HERELINK ALWAYS wanted more money around $75-100

This may help you.